<!DOCTYPE html><html lang="en"><head><title>Trump endorses Dr. Oz in Pennsylvania’s Senate primary race</title><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=242" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=242" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=242" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-kosa-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=242"/><link rel="stylesheet" href="https://gray-kosa-prod.cdn.arcpublishing.com/pf/resources/dist/kosa/css/main.css?d=242"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/kosa/favicon.ico?d=242"/><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2022 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=1102853867"/><meta name="google-play-app" content="app-id=com.graytv.android.kosanews"/><meta name="burst" content="kosa"/><meta property="og:url" content="https://www.cbs7.com/2022/04/11/trump-endorses-dr-oz-pennsylvanias-senate-primary-race/"/><link rel="canonical" href="https://www.cbs7.com/2022/04/11/trump-endorses-dr-oz-pennsylvanias-senate-primary-race/"/><meta name="robots" content="index,follow,noarchive"/><meta name="googlebot" content="index"/><meta name="googlebot-news" content="index"/><meta itemProp="description" name="description" content="Former President Donald Trump endorsed Mehmet Oz in Pennsylvania’s crowded Republican Senate primary, ending months of jockeying for his support."/><meta property="og:description" content="Former President Donald Trump endorsed Mehmet Oz in Pennsylvania’s crowded Republican Senate primary, ending months of jockeying for his support."/><meta name="twitter:description" content="Former President Donald Trump endorsed Mehmet Oz in Pennsylvania’s crowded Republican Senate primary, ending months of jockeying for his support."/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="462729160578650"/><meta property="fb:pages" content="90598169532"/><meta property="article:publisher" content="https://www.facebook.com/CBS7News/"/><meta name="keywords" content="Trump,Oz,Dr. Oz,Senate,primary,endorsement"/><meta name="news_keywords" content="Trump,Oz,Dr. Oz,Senate,primary,endorsement"/><meta itemProp="image" property="og:image" content="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/4hhE_fGY3CRtA1pHOOIZitjLXEw=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/VJH5CSNRMBDUPEMXADCGQS54XM.jpg"/><meta name="twitter:image" content="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/4hhE_fGY3CRtA1pHOOIZitjLXEw=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/VJH5CSNRMBDUPEMXADCGQS54XM.jpg"/><meta property="og:site_name" content="https://www.cbs7.com"/><meta property="og:title" content="Trump endorses Dr. Oz in Pennsylvania’s Senate primary race"/><meta name="twitter:title" content="Trump endorses Dr. Oz in Pennsylvania’s Senate primary race"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@CBS7News"/><meta name="twitter:creator" content="@CBS7News"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "KOSA",
  "url": "https://www.cbs7.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.cbs7.com/pf/resources/images/logo-off-site/kosa.png?d=242"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/CBS7News/",
    "https://www.instagram.com/cbs7news/",
    "https://www.twitter.com/CBS7News/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "Trump endorses Dr. Oz in Pennsylvania’s Senate primary race",
  "url": "https://www.cbs7.com/2022/04/11/trump-endorses-dr-oz-pennsylvanias-senate-primary-race/",
  "image": "https://gray-kosa-prod.cdn.arcpublishing.com/resizer/4hhE_fGY3CRtA1pHOOIZitjLXEw=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/VJH5CSNRMBDUPEMXADCGQS54XM.jpg",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "description": "Former President Donald Trump endorsed Mehmet Oz in Pennsylvania’s crowded Republican Senate primary, ending months of jockeying for his support.",
  "keywords": [
    "Trump",
    "Oz",
    "Dr. Oz",
    "Senate",
    "primary",
    "endorsement"
  ],
  "headline": "Trump endorses Dr. Oz in Pennsylvania’s Senate primary race",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.cbs7.com/2022/04/11/trump-endorses-dr-oz-pennsylvanias-senate-primary-race/"
  },
  "author": {
    "@type": "Person",
    "name": "Associated Press"
  },
  "publisher": {
    "name": "KOSA",
    "url": "https://www.cbs7.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.cbs7.com/pf/resources/images/logo-off-site/kosa.png?d=242"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2022-04-11T14:28:24.442Z",
  "datemodified": "2022-04-11T14:28:24.442Z"
}</script><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CObject.fromEntries%2CArray.prototype.entries"></script><script type="text/javascript" src="https://gray-kosa-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=242"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2uqt8vMBzVE8ysoUPRuScgOfUTLSxxshLp42fUXKpwxp6K4sX7OUt5C-",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2xxeKTDBGozmnljkUXiXBlleQF_-BKDifrtM03C3fFNzxG2gn4TFRND8fOu2Z5QDckfnsgtAyw",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript"> (function() {
    var purl = window.location.href;
    var url = '//ads.pubmatic.com/AdServer/js/pwt/161733/6819';
    var profileVersionId = '';
    if(purl.indexOf('pwtv=')>0){
        var regexp = /pwtv=(.*?)(&|$)/g
        var matches = regexp.exec(purl);
        if(matches.length >= 2 && matches[1].length > 0){
            profileVersionId = '/'+matches[1];
        }
    }
    var wtads = document.createElement('script');
    wtads.async = true;
    wtads.type = 'text/javascript';
    wtads.src = url+profileVersionId+'/pwt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(wtads, node);
})();
  </script><script id="a1c1c57f95064f50bba9396a0b142ced">!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script><script type="text/javascript" async="" src="https://widgets.outbrain.com/outbrain.js"></script><script type="text/javascript">!(function () {window.PianoESPConfig = {id: 362,};var e = document.createElement("script");e.setAttribute("id", "pnesplucidsdksel"),(e.type = "text/javascript"),(e.src = "https://api-esp.piano.io/public/sdk/v04/sdk.js?v="+((localStorage && localStorage.lucidsdkver) || "xxx")),(e.async = !0),document.getElementsByTagName("script")[0].parentNode.appendChild(e);})();</script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/news/national",
        authors: [ {
            _id:  "associated-press",
            name:  "Associated Press",
            type:  "author"
          }],
        canonicalUrl: "https://www.cbs7.com/2022/04/11/trump-endorses-dr-oz-pennsylvanias-senate-primary-race/",
        contentId: "N3CMOAST5REU5NGCP4DJ35BCEI",
        contentKewords: [ "Trump","Oz","Dr. Oz","Senate","primary","endorsement"],
        contentName: "Trump endorses Dr. Oz in Pennsylvania\'s Senate primary race",
        contentOwner: "dcc-gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "04/11/2022",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "AP National",
        distributorReferenceId: "170b8dd9-e05d-40d7-a567-b1adf5dcfdc7",
        distributorSubCategory: "the-associated-press",
        hasVideo: false,
        metaDescription: "Former President Donald Trump endorsed Mehmet Oz in Pennsylvania\'s crowded Republican Senate primary, ending months of jockeying for his support.",
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/news/national",
          name:  "National",
          path:  "/news/national"
        },
        publishedDay: "11",
        publishedMonth: "04",
        publishedYear: "2022",
        stationName: "kosa",
        subtype: "default",
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: (new Date()).toString(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script><script>
    (function() {
      var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
      _sf_async_config.uid = 39189;
      _sf_async_config.domain = "cbs7.com";
      _sf_async_config.useCanonical = true;
      _sf_async_config.useCanonicalDomain = true;
      _sf_async_config.authors = "Associated Press";
      _sf_async_config.type = "story";
      _sf_async_config.sections = "/news/national";
      _sf_async_config.flickerControl = false;
    })();
  </script><script async="" data-integration="chartbeat" src="//static.chartbeat.com/js/chartbeat.js"></script><script async="" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-36901b14-d673-4dee-a885-89977e5d1a11","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(e){var n="https://s.go-mpulse.net/boomerang/";if("False"=="True")e.BOOMR_config=e.BOOMR_config||{},e.BOOMR_config.PageParams=e.BOOMR_config.PageParams||{},e.BOOMR_config.PageParams.pci=!0,n="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="DC54J-CPWC3-7VEW3-BX6NP-N37JF",function(){function e(){if(!o){var e=document.createElement("script");e.id="boomr-scr-as",e.src=window.BOOMR.url,e.async=!0,i.parentNode.appendChild(e),o=!0}}function t(e){o=!0;var n,t,a,r,d=document,O=window;if(window.BOOMR.snippetMethod=e?"if":"i",t=function(e,n){var t=d.createElement("script");t.id=n||"boomr-if-as",t.src=window.BOOMR.url,BOOMR_lstart=(new Date).getTime(),e=e||d.body,e.appendChild(t)},!window.addEventListener&&window.attachEvent&&navigator.userAgent.match(/MSIE [67]\./))return window.BOOMR.snippetMethod="s",void t(i.parentNode,"boomr-async");a=document.createElement("IFRAME"),a.src="about:blank",a.title="",a.role="presentation",a.loading="eager",r=(a.frameElement||a).style,r.width=0,r.height=0,r.border=0,r.display="none",i.parentNode.appendChild(a);try{O=a.contentWindow,d=O.document.open()}catch(_){n=document.domain,a.src="javascript:var d=document.open();d.domain='"+n+"';void(0);",O=a.contentWindow,d=O.document.open()}if(n)d._boomrl=function(){this.domain=n,t()},d.write("<bo"+"dy onload='document._boomrl();'>");else if(O._boomrl=function(){t()},O.addEventListener)O.addEventListener("load",O._boomrl,!1);else if(O.attachEvent)O.attachEvent("onload",O._boomrl);d.close()}function a(e){window.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!window.BOOMR||!window.BOOMR.version&&!window.BOOMR.snippetExecuted){window.BOOMR=window.BOOMR||{},window.BOOMR.snippetStart=(new Date).getTime(),window.BOOMR.snippetExecuted=!0,window.BOOMR.snippetVersion=12,window.BOOMR.url=n+"DC54J-CPWC3-7VEW3-BX6NP-N37JF";var i=document.currentScript||document.getElementsByTagName("script")[0],o=!1,r=document.createElement("link");if(r.relList&&"function"==typeof r.relList.supports&&r.relList.supports("preload")&&"as"in r)window.BOOMR.snippetMethod="p",r.href=window.BOOMR.url,r.rel="preload",r.as="script",r.addEventListener("load",e),r.addEventListener("error",function(){t(!0)}),setTimeout(function(){if(!o)t(!0)},3e3),BOOMR_lstart=(new Date).getTime(),i.parentNode.appendChild(r);else t(!1);if(window.addEventListener)window.addEventListener("load",a,!1);else if(window.attachEvent)window.attachEvent("onload",a)}}(),"".length>0)if(e&&"performance"in e&&e.performance&&"function"==typeof e.performance.setResourceTimingBufferSize)e.performance.setResourceTimingBufferSize();!function(){if(BOOMR=e.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var n="true"=="true"?1:0,t="",a="eow65cqxh3tdkysuitnq-f-de54ce609-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,o={"ak.v":"32","ak.cp":"913335","ak.ai":parseInt("584710",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"36ed3f7","ak.r":38220,"ak.a2":n,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"35.173.238.0","ak.cport":49314,"ak.gh":"23.61.10.53","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1649689819","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==ZKdvbDIgqJ+pjZMLGWoClVeRwE75mL9p/Mv2r1soiwK99E+MnxkQf1vQkDk8Qkk7o4Mgb0mgNUu3IHDzbX2kylbqsg4KwGLrK402ACUYY0fphFweZyJjLJDblpVwtUbwQFypoagaW7whVl+hq/yLCgl6qn7hvXxuKFcDbUDe56CO4ZS/gYNJ4aq2iaKAQ/FeTN3tqEUS2/tP9Uw4GCEccB+GOCKVZPSf+Gz6VWXp1Njcr1Mim7b9KaXR/D+hCW4TfqPL2ShDDOcbZb47e2T+TT7yyxPbbNriSVxjXmslU6HNtqwSqLSd2YTSRv3HslkeS1b0aqcB7Uz2eopR3bsdSemiBsvr2REziC4GY1PMnL0q5faYxUetWWTudL6qlJr6Mt7YnUc/0LdG2vXF+JhulLv0mh6r5J9CTVPEcbu5Bj4=","ak.pv":"11","ak.dpoabenc":"","ak.tf":i};if(""!==t)o["ak.ruds"]=t;var r={i:!1,av:function(n){var t="http.initiator";if(n&&(!n[t]||"spa_hard"===n[t]))o["ak.feo"]=void 0!==e.aFeoApplied?1:0,BOOMR.addVar(o)},rv:function(){var e=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(e)}};BOOMR.plugins.AK={akVars:o,akDNSPreFetchDomain:a,init:function(){if(!r.i){var e=BOOMR.subscribe;e("before_beacon",r.av,null,null),e("onbeacon",r.rv,null,null),r.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/kosa.jpg?d=242&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/kosa.svg?d=242&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/kosa.svg?d=242&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream/">Watch the News</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/contests">Contests</a></li></ul><form class="search-box bg-primary-branding d-flex flex-row rounded position-absolute zindex-high w-auto p-1" action="/search/" method="GET" role="search"><input type="text" class="form-control form-control-sm bg-primary-branding m-0 p-0 border-0" aria-label="Enter search term" id="expandable-search" name="searchTerm" placeholder="Search..."/><button class="btn border-0 text-white" aria-label="Toggle search bar" type="button"><i class="d-block fas fa-search"></i></button><button class="btn btn-sm text-white border border-secondary sr-only" aria-label="Toggle search bar" type="submit">Search</button></form></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/homepage">Home</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/local">Local</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/international">International</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/health">Health</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">State</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/cams">Eye Cams</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream/">Watch the News</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graytvlocal.com/market/midland-odessa-tx" rel="noopener noreferrer" target="_blank">Shop West Texas</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/scoreboard/">Scores</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/helping-hands">Helping Hands</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/politics/election-results">Election Results</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Election Results navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics/national-election-map/">National Results Map</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/be-a-buddy">Be A Buddy</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/be-excellent">Be Excellent</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us/meet-the-team">Meet the Team</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener noreferrer" target="_blank">KOSA Careers</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/story-submission-3/">Story Submission</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/contests">Contests</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/vote">Vote</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/covid-19-map/">COVID-19 Map</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news/education">Education</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">TV Listings</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/captioning-information/">Captioning Information</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.fullcourtgreta.com/" rel="noopener noreferrer" target="_blank">Full Court Press with Greta Van Susteren</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.circleplus.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com/" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/mr-food/">Mr. Food</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation/">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/publishers/299/kosa/vod" rel="noopener noreferrer" target="_blank">Latest Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit KOSA on FACEBOOK" class="p-2" href="https://www.facebook.com/CBS7News" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit KOSA on INSTAGRAM" class="p-2" href="https://www.instagram.com/cbs7news" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a aria-label="Visit KOSA on TWITTER" class="p-2" href="https://www.twitter.com/CBS7News" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a aria-label="Visit KOSA on YOUTUBE" class="p-2" href="https://www.youtube.com/user/CBS7News" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div></nav><section class="leaderboard | w-100"><div class="arc-ad | text-center ad-flex-leaderboard py-2 d-flex flex-column mt-3 mb-3 justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="text-body text-uppercase mx-3 small">Advertisement</div><div id="ad-FRnx1Ra35Kl" class="kosa/web/news/national arcad"></div></div></div></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>Trump endorses Dr. Oz in Pennsylvania’s Senate primary race</span></h1></div><div class="lead-art | col-12"><figure class="image | figure mb-0 constrained image-ratio-16x9"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Former President Donald Trump has formally endorsed Mehmet Oz in Pennsylvania&#x27;s crowded..." height="675" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/4CgbfzaII9wctEyQkaR57DAWWfU=/1200x675/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/VJH5CSNRMBDUPEMXADCGQS54XM.jpg" width="1200"/></div><figcaption class="figure-caption">Former President Donald Trump has formally endorsed Mehmet Oz in Pennsylvania&#x27;s crowded Republican Senate primary.<span class="ml-2">(Christopher Dolan/The Times-Tribune via AP, File, AP Photo/Chris Seward)</span></figcaption></figure></div><div class="byline | col-12"><div class="authors |"><span class="">By </span><span class="author |"><a class="text-decoration-none" href="/authors/associated-press/">The Associated Press</a></span><span></span></div></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published: <!-- -->Apr. 11, 2022 at 9:28 AM CDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated: <!-- -->41 minutes ago</span></div><div class="sharebar |  col-12"><div class="btn p-0 facebook" role="button"><svg class="icon |  facebook pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Facebook</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.991 3.657 9.128 8.438 9.878v-6.987h-2.54V12h2.54V9.797c0-2.506 1.492-3.89 3.777-3.89 1.094 0 2.238.195 2.238.195v2.46h-1.26c-1.243 0-1.63.771-1.63 1.562V12h2.773l-.443 2.89h-2.33v6.988C18.343 21.128 22 16.991 22 12c0-5.523-4.477-10-10-10" fill-rule="evenodd"></path></svg></div><div class="btn p-0 mail" role="button"><svg class="icon | mail pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Email This Link</title><path d="M3.313 5.273C3.493 5.103 3.734 5 4 5h16c.13 0 .253.025.366.07L11.79 12.49 3.313 5.273zM21 7.166V18a1 1 0 0 1-1 1H4a1 1 0 0 1-1-1V7.775l8.064 6.867c.376.32.945.305 1.338-.036L21 7.166z" fill-rule="nonzero"></path></svg></div><div class="btn p-0 twitter" role="button"><svg class="icon | twitter pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Twitter</title><path d="M8.29 20.251c7.547 0 11.675-6.253 11.675-11.675 0-.178 0-.355-.012-.53A8.35 8.35 0 0 0 22 5.92a8.189 8.189 0 0 1-2.357.646 4.117 4.117 0 0 0 1.804-2.27 8.222 8.222 0 0 1-2.605.996 4.107 4.107 0 0 0-6.993 3.743 11.65 11.65 0 0 1-8.457-4.287 4.106 4.106 0 0 0 1.27 5.477A4.073 4.073 0 0 1 2.8 9.713v.052a4.105 4.105 0 0 0 3.292 4.022 4.095 4.095 0 0 1-1.853.07 4.108 4.108 0 0 0 3.834 2.85A8.233 8.233 0 0 1 2 18.407a11.617 11.617 0 0 0 6.29 1.84" fill-rule="evenodd"></path></svg></div><div class="btn p-0 pinterest" role="button"><svg class="icon | pinterest pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on Pinterest</title><path d="M12 2C6.477 2 2 6.477 2 12c0 4.239 2.634 7.86 6.354 9.317-.09-.79-.165-2.008.033-2.873.18-.781 1.169-4.97 1.169-4.97s-.297-.602-.297-1.482c0-1.391.807-2.428 1.811-2.428.856 0 1.267.642 1.267 1.407 0 .856-.543 2.14-.83 3.334-.24.995.501 1.81 1.48 1.81 1.778 0 3.145-1.876 3.145-4.576 0-2.395-1.72-4.066-4.181-4.066-2.848 0-4.519 2.132-4.519 4.338 0 .856.33 1.777.74 2.28.083.098.091.189.067.288-.074.312-.247.995-.28 1.135-.041.181-.148.223-.338.132-1.25-.584-2.033-2.403-2.033-3.876 0-3.153 2.289-6.05 6.61-6.05 3.465 0 6.164 2.47 6.164 5.778 0 3.449-2.173 6.222-5.185 6.222-1.012 0-1.967-.527-2.288-1.152l-.626 2.379c-.222.872-.83 1.958-1.242 2.625.938.288 1.926.444 2.963.444 5.522 0 10-4.477 10-10A9.98 9.98 0 0 0 12 2" fill-rule="evenodd"></path></svg></div><div class="btn p-0 linkedin" role="button"><svg class="icon | linkedin pointer" width="24" height="24" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Share on LinkedIn</title><path d="M4.329 3H19.67C20.405 3 21 3.595 21 4.329V19.67c0 .734-.595 1.329-1.329 1.329H4.33A1.329 1.329 0 0 1 3 19.67V4.329C3 3.595 3.595 3 4.329 3zM18.35 17.901v-5.316c0-2.626-1.632-3.522-3.142-3.522-1.396 0-2.31.904-2.572 1.433h-.035V9.305H10V17.9h2.706v-4.66c0-1.243.787-1.847 1.59-1.847.76 0 1.349.427 1.349 1.812v4.695h2.706zM7.56 8.107c.86 0 1.56-.656 1.56-1.553C9.12 5.656 8.42 5 7.56 5 6.697 5 6 5.656 6 6.554c0 .897.698 1.553 1.56 1.553zm-1.354 9.788h2.706V9.298H6.207v8.597z" fill-rule="evenodd"></path></svg></div></div></div></section><section class="body | w-100"><div class="article-body | article w-100"><p class="text | article-text">HARRISBURG, Pa. (AP) — Former President Donald Trump endorsed Mehmet Oz in Pennsylvania’s crowded Republican Senate primary, ending months of jockeying for his support.</p><p class="text | article-text">In a statement Saturday evening, Trump said his decision was “all about winning elections” as he formally backed the celebrity heart surgeon best known as the host of daytime TV’s “The Dr. Oz Show.”</p><p class="text | article-text">“The Great Commonwealth of Pennsylvania has a tremendous opportunity to Save America by electing the brilliant and well-known Dr. Mehmet Oz for the United States Senate,” Trump said, in part. Later, at a rally in North Carolina, he said: “You know when you’re in television for 18 years, that’s like a poll. That means people like you.”</p><p class="text | article-text">Oz had been competing for Trump’s endorsement in the May 17 primary against former hedge fund CEO David McCormick, whose wife, Dina Powell, served in Trump’s administration. The two had gone to extensive lengths to win over the former president, who remains deeply popular with the Republican base and has been wooed by candidates in primary races across the country.</p><div></div><p class="text | article-text">At a conservative forum in Pennsylvania last weekend, the candidates were asked if they would like Trump’s endorsement and for him to come to Pennsylvania to campaign for them.</p><p class="text | article-text">“That’s the easiest question we’re going to get all day,” replied one of the candidates, Jeff Bartos, a real estate investor. “Yes. 100%, yes.”</p><p class="text | article-text">The decision marks a disappointment for McCormick, who met with Trump last week and had hired a litany of former Trump aides for his campaign. Though he was virtually unknown to voters before declaring his candidacy in January, he topped a recent Fox News poll of Pennsylvania GOP primary voters.</p><p class="text | article-text">Trump had previously endorsed Sean Parnell in the race, but Parnell withdrew his candidacy amid allegations of abuse from his estranged wife. The turnabout raised questions about the vigor of Trump’s vetting process and concerns among Republicans about whether the former president was bolstering candidates who might be able to win their respective primaries but flounder in general elections that will determine which party controls the Senate.</p><div></div><p class="text | article-text">This time, Trump made clear that electability was top of mind. In his statement, he noted that Oz was a well-known quantity who has “lived with us through the screen and has always been popular, respected, and smart.”</p><p class="text | article-text">“Perhaps most importantly, I believe that Mehmet Oz will be the one most able to win the General Election against a Radical Left Democrat looking to do unthinkable harm to our Country,” he added. “Women, in particular, are drawn to Dr. Oz for his advice and counsel. I have seen this many times over the years. They know him, believe in him, and trust him,” he said.</p><p class="text | article-text">When Oz interviewed Trump on his show in 2016, Trump told him at one point that his wife, Melania Trump, was “a big fan” of the show.</p><p class="text | article-text">Oz also has a long personal history with Trump.</p><div></div><p class="text | article-text">Oz said in a recent interview that he had first met Trump in 2004 or 2005 when he asked Trump to use his golf course for an event for Oz’s children’s charity. Trump agreed. After that, they saw each other intermittently at social events before Oz interviewed Trump about his health during the 2016 presidential campaign.</p><p class="text | article-text">Trump, in conversations, has often praised Oz for his positive treatment on the show. “He even said that I was in extraordinary health, which made me like him even more (although he also said I should lose a couple of pounds!),” Trump wrote in his statement.</p><p class="text | article-text">McCormick, meanwhile, has made deep inroads with party donors and officials in Pennsylvania, and has landed endorsements from former Trump administration officials Sarah Sanders and Mike Pompeo. But he has had to work to turn himself into a pro-Trump, America First candidate.</p><p class="text | article-text">McCormick carries strong Republican establishment ties going back to his days in President George W. Bush’s administration. In 2015, McCormick held a fundraiser for Jeb Bush, Trump’s 2016 rival.</p><div></div><p class="text | article-text">That has opened McCormick, who spent a dozen years as an executive at one of the nation’s biggest hedge funds, to charges from some conservatives that he is a “globalist,” a derogatory term as adopted by Trump and others in his orbit to conjure up an elite, international coterie that doesn’t serve America’s best interests.</p><p class="text | article-text">Meanwhile, McCormick and a super PAC supporting him have spent millions attacking Oz.</p><p class="text | article-text">The ads pick apart Oz’s long career on TV and as a public personality and accuse him of being a liberal, pointing, for instance, to his repeated public advocacy for “Obamacare,” former President Barack Obama’s signature health care law. They also accuse Oz of being too “Hollywood.”</p><p class="text | article-text">Oz also has taken heat in the race for carpetbaggery. He lived in New Jersey for two decades until just before deciding to run in neighboring Pennsylvania, where his in-laws live.</p><div></div><p class="text | article-text">Trump’s decision drew criticism from some Oz critics, including Parnell, who endorsed McCormick.</p><p class="text | article-text">“I have enormous respect for President Trump. I was honored to have his endorsement in PA,” he tweeted. “But I’m disappointed by this. Oz is the antithesis of everything that made Trump the best president of my lifetime—he’s the farthest thing from America First &amp; he’d be very bad for PA.”</p><p class="text | article-text"><i>Copyright 2022 The Associated Press. All rights reserved.</i></p></div></section><section class="recommendations | w-100"><div id="fusion-static-enter:1c868bad-4391-4da5-abb7-9af29eb21f26" style="display:none" data-fusion-component="1c868bad-4391-4da5-abb7-9af29eb21f26"></div><div class="connatix | row mb-3"><div class="my-3 col"><div id="connatix-highlights-embed" class="w-100 h-100"><script id="a8e266bfac5841009afeb5359bf68301">
            cnxps.cmd.push(function() {
              cnxps({
              playerId: "1c868bad-4391-4da5-abb7-9af29eb21f26",
            }).render("a8e266bfac5841009afeb5359bf68301");
          });</script></div></div></div><div id="fusion-static-exit:1c868bad-4391-4da5-abb7-9af29eb21f26" style="display:none" data-fusion-component="1c868bad-4391-4da5-abb7-9af29eb21f26"></div></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Most Read</span></h4></div><div class="card-deck mx-n2 mb-0"><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/07/suspected-pipe-bomb-found-near-ector-county-courthouse/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Police are asking everyone to stay away from the area." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/inY1gnnLi_5a_iGtcawqAlEFNsc=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/TBC44FB2IJHTRNHGPGX67FXFJA.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/07/suspected-pipe-bomb-found-near-ector-county-courthouse/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Device with ‘bomb components’ destroyed at Ector County Courthouse </span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/03/major-accident-faudree-highway-191/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="(MGN)" height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/es8N6txSshYoK8C9Mnm9DLtNjAg=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/YGSAHXPSFJCXNAXYWSRR4EX3NQ.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/03/major-accident-faudree-highway-191/" rel="" target="_self"><span>UPDATE: One killed in major accident on Faudree </span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/08/cbs7-obtains-picture-bomb-like-device-that-was-destroyed-outside-ector-county-courthouse/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Bomb-like device found" height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/7obfhDHJ6IO5CGGMWWbsr4MtuEk=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/ZS2DQI5JTZAJRGCICVBIHJMBAM.png" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/08/cbs7-obtains-picture-bomb-like-device-that-was-destroyed-outside-ector-county-courthouse/" rel="" target="_self"><span>CBS7 obtains picture of bomb-like device that was destroyed outside of Ector County Courthouse</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/04/midland-police-asking-help-finding-missing-person/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Photo of Nathaniel Machuca" height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/_dKNCvdy6qSa_gG3M4D2NKDXIw0=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/2Z77JDMEEBCJLIOW34T3RLBJ6U.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/04/midland-police-asking-help-finding-missing-person/" rel="" target="_self"><span>Midland Police asking for help finding missing person</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-right position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-right ml-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/06/missing-indiana-couple-found-nevada-desert-man-dead-wife-hospitalized-family-says/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Ronnie and Beverly Barker’s nephew, Travis Peters, posted an update on Facebook last Tuesday..." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/EsfIGinq86VN-r8j82GrW8f9IKg=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/RX524RH4ANBN7GYO6SQ6TTKZL4.jpeg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/06/missing-indiana-couple-found-nevada-desert-man-dead-wife-hospitalized-family-says/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Missing Indiana couple found in Nevada desert; man dead, wife hospitalized, family says</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div></div></div><div></div><div class="flex-feature-feed | mb-0"><div class="title-bar | w-100"><h4 class="title | font-weight-bold"><span class="">Latest News</span></h4></div><div class="card-deck mx-n2 mb-0"><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/11/once-retail-giant-kmart-will-be-down-3-stores-after-nj-closing/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="The Kmart store in Avenel, New Jersey, will close permanently this week, leaving just three..." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/T_8Js3ZL-DkYJ3PaIcmg5GmJBHw=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/QFQYLXBOZZDBJGYSE7WTQIM4FY.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/11/once-retail-giant-kmart-will-be-down-3-stores-after-nj-closing/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>Once a retail giant, Kmart will be down to 3 stores after NJ closing</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/11/atlanta-airport-reclaims-title-worlds-busiest-airport/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="FILE - In this Wednesday, Feb. 3, 2021, file photo, a passenger wears a face mask she travels..." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/XMXjgXibDGcUU5UAk8e0TK4OxdM=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/HLAZTDV7FNESTJVK4RG32VRIEA.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/11/atlanta-airport-reclaims-title-worlds-busiest-airport/" rel="" target="_self"><span>Atlanta airport reclaims title as World’s Busiest Airport</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/11/city-midland-animal-services-facility-will-operate-by-appointment-only/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="(Source: City of Midland)" height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/XiTJYsZYwIqFwds7wmoxueRpaAM=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/VETOQCBVI5C6TNMIHHTDGEU46I.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/11/city-midland-animal-services-facility-will-operate-by-appointment-only/" rel="" target="_self"><span>The City of Midland Animal Services Facility will operate by appointment only</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100 is-video"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/video/2022/04/11/ukraine-finding-way-out-after-train-station-attack/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="Cleanup efforts start at a train station in Krematorsk after a deadly Russian attack Friday...." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/x95-rVSV3SiqFOMVUbV-uKAZUNs=/800x450/smart/filters:quality(70)/do0bihdskp9dy.cloudfront.net/04-11-2022/t_2c222d69e5db434c854ac79890966260_name_file_1280x720_2000_v3_1_.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/video/2022/04/11/ukraine-finding-way-out-after-train-station-attack/" rel="" target="_self"><span>Ukraine: Finding a way out after train station attack</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div><div class="flex-feature | card mx-2 mb-3 align-items-start border image-left position-relative w-100"><div class="card-body w-100 px-2 py-1 image_headline"><div class="image-container position-relative mb-0 pt-0 w-33 float-left mr-2"><figure class="image | figure mb-0 constrained image-ratio-16x9"><a href="/2022/04/11/how-publics-view-obamacare-has-changed-last-12-years/" rel="" target="_self" class="link | text-reset d-block h-100 w-100"><div class="img-wrapper figure-img mb-0"><img class="rounded-0 img-fluid" alt="President Joe Biden applauds as former President Barack Obama arrives on stage during an event..." height="450" src="https://gray-kosa-prod.cdn.arcpublishing.com/resizer/GcnHB6tA9rAsxpzVEqBZML_1gz8=/800x450/smart/filters:quality(70)/cloudfront-us-east-1.images.arcpublishing.com/gray/PV5RCAPBB5DIFDDENYHW7IIFKY.jpg" width="800"/></div></a></figure></div><div class="headlines | card-title mb-1"><h6 class="headline | mb-0 font-weight-bold"><a class="text-reset" href="/2022/04/11/how-publics-view-obamacare-has-changed-last-12-years/" rel="" target="_self"><span><i class="far fa-play-circle"></i><span style="textDecoration: none;"> </span>How the public’s view of Obamacare has changed in the last 12 years</span></a></h6></div></div></div><div class="feed-divider | w-100 d-none d-sm-block d-md-block d-lg-block d-xl-block"></div></div></div><div></div></section></div><section class="bottom-wrapped | col-12"><div></div></section></div></div><footer class="footer | w-100"><div class="arc-ad | text-center ad-flex-leaderboard ad-flex-footer-leaderboard ad-fixed-bottom position-fixed zindex-higher w-100 py-0 my-0 d-flex flex-column justify-content-center ad-type-flex-leaderboard"><div class="arc-ad-wrapper | d-flex flex-column"><div class="ad-dismiss | text-white pointer position-absolute top absolute-right p-1" role="button"><i class="far fa-times-circle fa-sm"></i></div><div id="ad-FFyqG6utofd" class="kosa/web/news/national arcad"></div></div></div><div id="fusion-static-enter:footer-kosa" style="display:none" data-fusion-component="footer-kosa"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news/crime">Crime</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news/energy">Energy</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news/state">State</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="https://www.facebook.com/CBS7News/" rel="noopener noreferrer" target="_blank">Facebook</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/programming/schedule">TV Listings</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">KOSA</li><li class="footer-contact | footer-address">4101 East 42nd Street J7</li><li class="footer-contact | footer-address">Music City Mall</li><li class="footer-contact | footer-city-state">Odessa, TX 79762</li><li class="footer-contact | footer-phone">(432) 580-5672</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/KOSA-TV" rel="noopener noreferrer" target="_blank">Public Inspection File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:publicfile@cbs7.com" rel="noopener noreferrer" target="_blank">publicfile@cbs7.com - (432) 580-5672</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/kosa-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service/" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy/" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/api/manager/download/7ec831bd-3ee0-8757-f9f0-33fa62edcff9/c94f6c5b-9c65-4ead-87d7-11290118890e.pdf" rel="noopener noreferrer" target="_blank">EEO Statement</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising/" rel="noopener noreferrer" target="_blank">Advertising</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2022 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-kosa" style="display:none" data-fusion-component="footer-kosa"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>